Email service provider disruption
Incident Report for Trustgrid Public
Resolved
This incident has been resolved.
Posted Jul 26, 2019 - 07:48 CDT
Update
Email service has been restored. We are investigating ways to prevent in the future.
Posted Jul 26, 2019 - 07:45 CDT
Update
We are continuing to work on a fix for this issue.
Posted Jul 25, 2019 - 21:35 CDT
Identified
We're having difficulties interacting with our email service provider. The invite user function won't send emails while we address the issue. Invites will still create user accounts if a user signs up with the same email address the invitation was meant to be sent to. No other features are affected.

If you need to add a user urgently, please contact support.
Posted Jul 25, 2019 - 21:35 CDT
This incident affected: Management (User Management).