AWS Issues impacting Trustgrid services
Incident Report for Trustgrid Public
Resolved
We are pleased to inform you that AWS has resolved the issues that were impacting our services. Full functionality has been restored, and nodes are now able to download updated configurations as intended. You can now proceed with making changes in our portal, which will be applied successfully. Thank you for your patience and understanding during this outage. If you have any further questions or concerns, please don't hesitate to reach out to our support team.
Posted Jun 13, 2023 - 16:19 CDT
Update
We would like to provide you with an update regarding the AWS outage. It appears that the issues have been resolved, and we are currently observing normal functionality being restored. However, we are continuing to closely monitor the situation to ensure stability. At this time, nodes should be able to download updated configurations, and changes made in our portal are expected to be applied correctly. We appreciate your patience, and we will keep you informed of any further developments. If you have any questions or require assistance, please feel free to contact our support team.
Posted Jun 13, 2023 - 15:50 CDT
Monitoring
Due to the ongoing AWS outage, nodes are currently unable to download updated configurations. As a result, any changes made in our portal will not be applied until the issue is resolved. We apologize for the inconvenience and will notify you once the situation is resolved.
Posted Jun 13, 2023 - 15:31 CDT
Update
Trustgrid is still monitoring the situation and investigating for additional impacts at this time.
Posted Jun 13, 2023 - 14:59 CDT
Update
This outage is also preventing new logins to the Trustgrid management portal. If you are already logged in you are not impacted by this.
Posted Jun 13, 2023 - 14:28 CDT
Investigating
AWS appears to be having issues in their us-east-1 region that are degrading the Trustgrid control plane. We are investigating the full impact but we have seen that the Management Gateways that allow for interactive services such as Terminal are currently down. We will update as we learn more.
Posted Jun 13, 2023 - 14:25 CDT
This incident affected: Node (Cloud Controller) and Management (Management Portal, Management Gateways).